WELCOME HOME, E-TREK!

Exactly four weeks after our E-trek was picked up for service at the Roadtrek factory, it was delivered back to us. We were very excited to see our old friend, and it was the one bright spot on this rainy first weekend in October. We had actually been expecting the delivery since Wednesday, since it was loaded on Tuesday afternoon; however, due to various technical difficulties, the delivery was delayed until Friday.

All looked good as the driver unloaded it off the flatbed. It was considerably simpler than the loading on September 4th, which took 1.5 hours. For the trip to Canada, the truck was a car carrier and the driver seemed surprised by the size of the unit. He took a number of measurements and then had to check with his boss to make sure they would be within the height and overhang limits. Of course, this made us very nervous. The flatbed truck it arrived home on is what we expected, and the unload took less than 15 minutes.

Since we live at the top of a steep, narrow, dead-end road, we had to meet both the outgoing and incoming trucks at a fire department/rescue squad parking lot about 1/2 mile from our house. Needless to say, we were very nervous having our second home away from us for so long; however, we are happy to report that there was not the slightest sign of any mishandling during the past month and our E-trek was clearly treated with TLC while away from home.

  • After driving home, the first thing we did was check the battery, and we were pleased to see it was charged to 99%/27 VDC.
    IMG_6661   
  • We also admired the new flat surface where the front table mount used to be. It’s a small thing, but it always seemed to be in the way when we taking the dogs in or out. Furthermore, since we use the top of the crate as a table top, there is no need to mount the table.
    IMG_6169  IMG_6663
  • The rusty magnets had been replaced on the utility bay door.
    IMG_6167  IMG_6708
  • The warped cabinet had been replaced–in fact, all of the cabinets seemed to be working better than ever!
  • The new battery monitor panel was working reliably. Now all four red lights illuminated when the batteries were fully charged, and the blue light came on each time we toggled the battery disconnect switch.

The rain continued, but we were still anxious to take our new and improved E-trek out for a test run. We were on the road by 7:15 AM on Saturday morning for an 8:00 AM dentist appointment. When we departed, the battery strength was 91%/25 volts. While we were on the road, we checked the strength again, and it was at 100%/28 volts while driving, so charging by driving was working as expected. When we arrived at our destination (about 35 miles) and stopped the engine, the battery strength was at 99%.

Before we left home, Karl had sanitized the fresh water tank with 1/2 cup bleach, and filled up the fresh water tank about 3/4 full so it could slosh around on the drive. He also put the Webasto hot water heater on summer mode/hot water production; however, when I went back to check the battery strength, I switched it to winter mode/heat with hot water production. This produced an error signal (series of flashing lights), so the water had not been heating up during the drive.

While Karl was in the dentist, I turned off the Webasto and turned it back on to the correct setting (winter mode/heat with hot water production). I also let water run through the faucets for a few minutes, and flushed the toilet a few times to let the bleach run through. I enjoyed relaxing on the sofa, warm heat pouring in at my feet, while Karl was at the dentist. Before we left at 8:50 AM, we checked the battery strength which was at 87%/25 Volts after running the Webasto on full strength to heat the unit and water. When we got home at 9:45 AM, the battery was again fully charged to 96%/26 Volts and the water was hot. We flushed the lines again. Tomorrow we will drain and add the vinegar to counteract the bleach. (We use bottled water for drinking and cooking, so we don’t particularly worry about a little bleach residue.)

Our preliminary testing indicates that the batteries are now charging properly by driving with the new and improved underhood generator/secondary alternator. Over the next few days we will continue testing the charging capabilities of the solar panels, as well as the underhood generator/secondary alternator by driving and idling. We are planning a few trips over the next few weeks, so we will be able to test the improved performance of the batteries with the new balancer/equalizer.

3 thoughts on “WELCOME HOME, E-TREK!

  1. I picked up my 2016 CS Adventurous on Jan 3rd and have major battery and water issues. How did get Roadtrek to pick up repair and return your Roadtrek.

    1. What are the specific problems with your battery and water? We discovered our battery didn’t seem to be charging when we started taking trips in late April/early May 2015 and corresponded with both our dealer’s and Roadtrek’s service departments. The low battery was also causing the Webasto hot water heater to drain. Since we were new RVers, we didn’t know if it was “user error,” so initially we were just trying to make sure we were doing everything correctly. When our low coolant light went on, we took our E-trek to Mercedes-Benz and they discovered the serpentine belt had slipped off, hence the secondary alternator (aka underhood generator) could not charge the batteries. Mercedes-Benz repaired this issue several times (using Roadtrek-supplied parts); however, when it occurred a third time, our dealer contacted Roadtrek and within a week, our E-trek was Canada-bound. Please see our posts from May-September for more details.

Leave a Reply

Your email address will not be published. Required fields are marked *